Skip to content

kriansa/PKGBUILDs

Repository files navigation

Arch PKGBUILDs

This repository is composed of PKGBUILDs I have written for myself or maintain at some point (and those are available at AUR).

Adding a new AUR

$ pkgname=mycoolnewpkg
$ mkdir _$pkgname && cd _$pkgname
$ git init
$ git branch -M master
$ git remote add origin ssh://[email protected]/$pkgname.git
$ touch PKGBUILD

Then do your thing, make sure it works with makepkg -fsri and finally:

$ makepkg --printsrcinfo > .SRCINFO
$ git add PKGBUILD .SRCINFO
$ git commit -m "feat: initial commit"
$ git push
$ xdg-open https://aur.archlinux.org/packages/$pkgname

Do your editing on the UI, now lets add it as a submodule to the enclosure repository.

$ cd ..
$ git remote add origin ssh://[email protected]/$pkgname.git
$ rm -rf _$pkgname

License

The contents of this repository are licensed under Apache v2.

About

My repository of Arch Linux PKGBUILDs

Topics

Resources

License

Stars

Watchers

Forks

Languages